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Preface 

The Construction Industry Council (CIC) is committed to seeking continuous 
improvement in all aspects of the construction industry in Hong Kong. To achieve this 
aim, the CIC forms Committees, Task Forces and other forums to review specific areas 
of work with the intention of producing Alerts, Reference Materials, Guidelines and 
Codes of Conduct to assist participants in the industry to strive for excellence. 

The CIC appreciates that some improvements and practices can be implemented 
immediately whilst others may take more time for implementation. It is for this reason 
that four separate categories of publication have been adopted, the purposes of which 
are as follows: 

Alerts The Alerts are reminders in the form of brief leaflets produced 
quickly to draw the immediate attention of relevant stakeholders 
to the need to follow some good practices or to implement some 
preventive measures in relation to the construction industry. 

Reference 
Materials 

The Reference Materials are standards or methodologies 
generally adopted and regarded by the industry as good 
practices. The CIC recommends the adoption of the Reference 
Materials by industry stakeholders where appropriate. 

Guidelines The Guidelines provide information and guidance on particular 
topics relevant to the construction industry. The CIC expects all 
industry stakeholders to adopt the recommendations set out in 
the Guidelines where applicable. 

Codes of 
Conduct 

The Codes of Conduct set out the principles that all relevant 
industry participants should follow. Under the Construction 
Industry Council (Cap 587), the CIC is tasked to formulate codes 
of conduct and enforce such codes. The CIC may take necessary 
actions to ensure compliance with the codes. 

If you have read this publication, we encourage you to share your feedback with us. 
Please take a moment to fill out the Feedback Form attached to this publication in order 
that we can further enhance it for the benefit of all concerned. With our joint efforts, we 
believe our construction industry will develop further and will continue to prosper for 
years to come. 



Foreword 
I am glad to see the release of CIC BIM User Guide for Preparation of Statutory 
Plan Submissions Tekla (December 2020). This software specific user guide shall 
be read in conjunction with the CIC BIM Standards for Preparation of Statutory Plan 
Submissions (December 2020).  

This software specific user guide is only provided to demonstrate the feasibility of 
drawings generation with the Standards.  

With the software specific user guides which contains step by step procedures of 
modelling, BIM users can easily apply the templates for the generation of statutory plan 
submission drawings. 

Feedback on the CIC BIM User Guide for Preparation of Statutory Plan Submissions 
Tekla (December 2020) from practitioners subsequent to the issuance of this 
publication will be considered in future revisions.  

On behalf of the CIC, I would like to thank everyone who has contributed to producing 
this CIC BIM User Guide for Preparation of Statutory Plan Submissions Tekla 
(December 2020), in particular to the members of the Task Force on BIM Standards. 

Ar. Ada FUNG, BBS 

Chairperson  

Committee on Building Information Modelling 

Construction Industry Council 

December 2020 
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1 Hardware / System Requirements 

1.1 General 
Hardware / system requirement for modellings, coordination and visualisation on 
desktop/notebook computers and mobile devices should be determined by the BIM managers for 
different projects on a case by case basis. The minimum requirement varies for different 
applications, project sizes and operating systems. 

https://teklastructures.support.tekla.com/support-articles/tekla-structures-2019-hardware-
recommendations 

https://teklastructures.support.tekla.com/support-articles/tekla-structures-2019-hardware-recommendations
https://teklastructures.support.tekla.com/support-articles/tekla-structures-2019-hardware-recommendations
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2 Tekla Basics 
 

This guideline only provides the necessary information to produce 2D statutory submission 
drawings. Please refer to the official website linked below for a complete understanding of Tekla.   
https://teklastructures.support.tekla.com/tekla-structures-2019-pdf-documentation 

 

2.1 User Interface 
Information of user interface could be found in the official website here: 

https://teklastructures.support.tekla.com/2019/en/gen_interface_overview 

 

2.2 Project base point, Grid, Levels and Work Planes  
 
Project base point defines the origin (0,0,0) of the project coordinate system initially Location of 
point can be determined by the project team or BIM manager as a reference point. Steps to set up 
project base points in Tekla could be found from the official website here :  
 
https://teklastructures.support.tekla.com/2019/en/int_base_point 
 
Grids and Levels are essential for users to model and identify objects in Tekla effectively, Steps to 
set up girds and levels in Tekla could be found from the official website here :  
 
https://teklastructures.support.tekla.com/2019/en/mod_grids 

https://teklastructures.support.tekla.com/2019/en/mod_creating_a_grid 
 
Work Plane is a vital concept for users to model objects in Tekla, this official link is useful for users 
to understand work planes in Tekla : 
 
https://teklastructures.support.tekla.com/190/en/mod_work_plane 

2.3 Parts and Components 
Tekla objects could be classified into parts, components, assemblies, cast units etc. In this user 
guide, users mainly need to use parts (for example; concrete parts such as beam, column, slabs 
and panels) and components (for example; rebar components). These official web pages provide 
good guidance for creating parts in Tekla: 
 

https://teklastructures.support.tekla.com/190/en/mod_creating_and_modifying_structures 

 

https://teklastructures.support.tekla.com/190/en/mod_creating_concrete_slab?da=_ 
 

Components in Tekla could greatly increase the efficiency of modelling works, information about 
components could be found in this official web site:   
 

https://teklastructures.support.tekla.com/tekla-structures-2019-pdf-documentation
https://teklastructures.support.tekla.com/2019/en/gen_interface_overview
https://teklastructures.support.tekla.com/2019/en/int_base_point
https://teklastructures.support.tekla.com/2019/en/mod_grids
https://teklastructures.support.tekla.com/2019/en/mod_creating_a_grid
https://teklastructures.support.tekla.com/190/en/mod_work_plane
https://teklastructures.support.tekla.com/190/en/mod_creating_and_modifying_structures
https://teklastructures.support.tekla.com/190/en/mod_creating_concrete_slab?da=_
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https://teklastructures.support.tekla.com/2017i/en/det_getting_started_overview 

2.4 Catalogs and Define Profiles 
Tekla allow users to define customised profiles for members sections; users may refer to the link 
below for more information  
 
https://teklastructures.support.tekla.com/2019/en/mod_profiles.  

2.5 Phases, View Filter and Organiser 
Phases are usually used by Tekla users to classify different object-groups (such as ELS, 
foundations or superstructures) in Tekla, differ from Revit, phase not necessarily be used to record 
sequential data of objects in Tekla. Users may use “Pour Phase” in Tekla to record chronological 
information of Tekla concrete parts. For steel parts and assemblies, part or assembly numbers are 
commonly used to achieve the same goal. 

https://teklastructures.support.tekla.com/2019/en/mod_dividing_the_model_into_phases 
 
In order to do 3d-modelling and produce drawings efficiently, phases are often used together with 
the view filter. View filter could also be used to control the visibility of different Tekla elements. 
More information about view filters could be found from the official website below :  
 
https://teklastructures.support.tekla.com/190/en/mod_creating_a_view_filter 

 
https://teklastructures.support.tekla.com/190/en/mod_filtering_parts_in_specific_phases 

Organisers are used mainly for quantity take off purpose in Tekla, this web page provides more 
information about organiser in Tekla, in this document, organiser would not be discussed as it is 
not related to statuary drawing submissions.  
 
https://teklastructures.support.tekla.com/2019/en/mod_organizer 
 
 

2.6 Suggested Model Nesting Method, Reference Models and Model Sharing 
Tekla is not designed to link-up with other Tekla models. For users who want to link two Tekla 
models together, they need to export one Tekla model as ifc and add that ifc model to another 
model via the “Reference Model” function in Tekla. 
 
Information about the reference model could be found in this official web page ; files such as ifc, 
dwg, dgn, skp, xml, etc. could all be linked to Tekla by using this method. 
   
https://teklastructures.support.tekla.com/2019/en/int_inserting_a_reference_model 

 
2D reference information, such as 2D dwg/dgn maps bought from the Lands Department website 
shall also be linked to Tekla file by using a reference model. 
 
Tekla allow multi-user-editing, please refer this web page for “Model Sharing” in Tekla 
 
https://teklastructures.support.tekla.com/2019/en/ms_what_is_model_sharing 

https://teklastructures.support.tekla.com/2017i/en/det_getting_started_overview
https://teklastructures.support.tekla.com/2019/en/mod_profiles
https://teklastructures.support.tekla.com/2019/en/mod_dividing_the_model_into_phases
https://teklastructures.support.tekla.com/190/en/mod_creating_a_view_filter
https://teklastructures.support.tekla.com/190/en/mod_filtering_parts_in_specific_phases
https://teklastructures.support.tekla.com/2019/en/mod_organizer
https://teklastructures.support.tekla.com/2019/en/int_inserting_a_reference_model
https://teklastructures.support.tekla.com/2019/en/ms_what_is_model_sharing
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2.7 Views and Drawings 
Views in Tekla are used to facilitate both 3D-modeling works and 2D drawing production. This web 
page summarises information about views in Tekla. 
 
https://teklastructures.support.tekla.com/2019/en/mod_views 
 

Users could produce 2D drawings after creating different views in Tekla. There are five different 
drawing types in Tekla, namely (1) general arrangement drawings, (2) single-part drawings, (3) 
assembly drawings, (4) Cast-unit drawings and (5) Multidrawings.  
 
For the production of statutory-submission, only general arrangement drawings will be discussed 
in this user guide. Please refer to the link below for more information about creating general 
drawings by Tekla. Tekla will be switched from modelling mode to drawing mode for drawing 
production. 
 
https://teklastructures.support.tekla.com/2019/en/dra_creating_ga_drawings_using_menu_t
oolbar_or_popup 

 

2.8 Annotation and Dimensioning 
Users can create annotation and dimensions on drawings in drawing mode. Below are some web 
page links for more information.  
 
https://teklastructures.support.tekla.com/2019/en/dra_arranging_drawing_objects 
 
https://teklastructures.support.tekla.com/2019/en/dra_manual_dimensions 

 
 

2.9 Template Editor, Tables and Drawing Layout 
Drawing frames, or so we call title block, were produced by template editor in Tekla. Template 
editor could also be used to produce schedules or tables in 2D drawings. This video provides a 
brief introduction about template editor in Tekla.   
 
https://teklastructures.support.tekla.com/video-tutorials/en/layout_editor 
 
https://teklastructures.support.tekla.com/system/files/document_attachments/TE_USG_380
_en_Template_editor_user_guide.pdf 

This video shows how the template editor could be used to produce schedules in 2D drawings.  

https://teklastructures.support.tekla.com/video-tutorials/en/introduction_to_template_editor 

  

https://teklastructures.support.tekla.com/2019/en/mod_views
https://teklastructures.support.tekla.com/2019/en/dra_creating_ga_drawings_using_menu_toolbar_or_popup
https://teklastructures.support.tekla.com/2019/en/dra_creating_ga_drawings_using_menu_toolbar_or_popup
https://teklastructures.support.tekla.com/2019/en/dra_arranging_drawing_objects
https://teklastructures.support.tekla.com/2019/en/dra_manual_dimensions
https://teklastructures.support.tekla.com/video-tutorials/en/layout_editor
https://teklastructures.support.tekla.com/system/files/document_attachments/TE_USG_380_en_Template_editor_user_guide.pdf
https://teklastructures.support.tekla.com/system/files/document_attachments/TE_USG_380_en_Template_editor_user_guide.pdf
https://teklastructures.support.tekla.com/video-tutorials/en/introduction_to_template_editor
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2.10 2D Library and Symbol Editor 

 Tekla has some features to enable users to manage 2D drawing pieces and 2D symbols. They are 
namely the 2D Library and symbol editor. Please refer to the links below for more information.   
 
https://teklastructures.support.tekla.com/video-tutorials/en/2d_library 
 
https://teklastructures.support.tekla.com/video-tutorials/en/add_symbols 
 
https://teklastructures.support.tekla.com/system/files/document_attachments/SE_USG_300_en_S
ymbol_editor_user_guide.pdf 

2.11 User Define Attributes 
Tekla enables users to introduce user-defined-attributes (UDA) to manage information about Tekla 
objects. An example of applying UDA to Tekla objects is provided as bored piles in the sample 
models. This requests users to acquire advanced Tekla skills, including some basic coding skills. 
For those who are interested, please refer to the link below, this user guide would not discuss this 
in detail. 
 
https://teklastructures.support.tekla.com/cs/191/en/sys_example_creating_and_updating_uda 

 
To manage UDA efficiently, Users may also search UDA in Tekla Warehouse and install more 
extensions: 
 
https://warehouse.tekla.com/#!/search/?searchTerm=uda 

 
Information stored in Tekla as UDA could also be exported to IFC as IFC property set, please refer 
to the link below for more information ; 
 
https://teklastructures.support.tekla.com/2019/en/int_defining_property_sets_using_proper
ty_set_definitions 

  

https://teklastructures.support.tekla.com/video-tutorials/en/2d_library
https://teklastructures.support.tekla.com/video-tutorials/en/add_symbols
https://teklastructures.support.tekla.com/system/files/document_attachments/SE_USG_300_en_Symbol_editor_user_guide.pdf
https://teklastructures.support.tekla.com/system/files/document_attachments/SE_USG_300_en_Symbol_editor_user_guide.pdf
https://teklastructures.support.tekla.com/cs/191/en/sys_example_creating_and_updating_uda
https://warehouse.tekla.com/#!/search/?searchTerm=uda
https://teklastructures.support.tekla.com/2019/en/int_defining_property_sets_using_property_set_definitions
https://teklastructures.support.tekla.com/2019/en/int_defining_property_sets_using_property_set_definitions
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3 Getting Start 
Users are expected to install Tekla 2019i before followings the steps stated in this section. 

3.1 Opening Project Template 
Download template file from CIC website. Run the Env_SE_Asia_2019.exe to install Asian Tekla 
tool set. Put the folder set ““CIC_TEMPLATE_STR_2019”” to C:\ProgramData\Trimble\Tekla 
Structures\2019.0\Environments\SE_Asia\Precast\model_templates. 
 

Open Tekla 2019, open new file with template “CIC_DEMO_MODEL_TEMPLATE” being chosen. 
 

 

3.2 Set-up of Project Base Points  
 

Chose a reference point in the target project. Enter the Easting and Northing coordinates to Tekla 
by clicking the “base point” button in the project property menu as shown in the pictures below  
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3.3 Creating Grids  
On the Edit tab, click Grid > Create rectangular grids as shown in the picture below; click “create 
rectangular grids” again to create another grid system if needed. The user could also create radial 
grids by choosing “Create radial grid”. Unlike Revit, Tekla uses grids in the Z dimension to define 
building levels. For details about grids in Tekla, please refer to the reference links in section 2.2 in 
this user guide.  

Grids are useful to control 3D objects in Tekla. Users could switch on or switch off the magnetic 
function of grids. The magnetic function is also available in construction lines and planes in Tekla. 
Users could use construction lines and construction planes as a temporary 3D reference during 3D 
modelling. Please refer to the link below for more information:  

https://teklastructures.support.tekla.com/video-tutorials/en/magnetic_construction_objects 

  

https://teklastructures.support.tekla.com/video-tutorials/en/magnetic_construction_objects
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4 Creating Model Objects 
The following objects will be modelled in Tekla: 

 Slab 

 Column 

 Wall 

 Beam 

 Lift Shaft 

 Staircase 

 Piles 

 Pile Caps 

 Tie Beams 

 Reinforcement 

 Steel members for ELS 

 Hoarding 

 Geotechnical Monitoring instruments 
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4.1 Creating Slabs 

 On the View tab, click View tab > new view > along gridline to create views for specific floor levels, 
click Work Plane > Parallel to view plane to create work plane parallel to the view. For the snap 
settings which could be adjusted at the right bottom corner choose a plan, work plan and grid 
plane in the three put down the menu. Press ctrl+P to get a top view in Tekla modelling space, 

 

 On 
the  
 

 Concrete tab, click Slab > Slab as shown in the picture below, left-click to define corner points of 
the slab, press middle mouse button to finish. Slab thickness can be adjusted in the property menu 
on the right. 
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4.2 Creating Columns 

 On the Concrete tab, click Column to create a column. Left-click in 3D model space to create a 
column. In the property menu, assign a name for the column; simply change the numbers in the 
profile entry in property menu (such as 250*675 or 400*600) to adjust column size; type D-
diameter length (such as D1800) to change it to a circular column. Press three dots at the right for 
specific section profile. Change values in Top and Bottom to adjust column elevation. Right-click 
the column and choose move special > linear to fine adjust the position of the column in 3D space.     

 
 

  



11 
 

4.3 Creating Panels ( Walls ) 

 On the concrete tab, click Panel > Panel to create walls. Left-click to define wall alignment on the 
plan view, press middle mouse button to finish. In the property menu, assign a name for the wall, 
Wall height and wall thickness can be adjusted in the profile entry in the property menu. 
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4.4 Creating Beams 

On the Concrete tab, click Beam > beam to create beams. Left-click in 3D model space to define 
endpoints of the beam. In the property menu, assign a name for the beams; like columns, simply 
change the numbers in the profile entry in property menu (such as 400*600 or 200*300) to adjust 
beam size; press three dots at the right for specific section profile. Right-click the beams and 
choose move special > linear to fine adjust the position of the beams in 3D space. 

 

  
 

For specially shaped beams such as haunch beam, stepped beams and cranked beams, it is 
suggested to use polygon cut to remove unwanted portion of the beam. 
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4.5 Creating Slab Openings  

Left-click the slab which needs to create slab opening, on the concrete tab, Press “ctrl+P” to get a 
top view in Tekla modelling space, choose polygon cut on the concrete tab to create slab opening. 

4.6 Creating a Staircase 

Click the application & components tab the right, search stair and chose concrete stair (component 
number 65) to create stair. Double-click the blue “M” symbol to adjust the properties of a 
component, click Modify > Apply > Okay to finish. Click the green buttons at the selection switches 
at the bottom to enable/disable user’s ability to choose parts inside components. Delete unwanted 
components if necessary. Deleted parts in the component will be regenerated whenever users 
click Apply > Okay in the component property menu.  
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4.7 Creating Piles 
Concrete piles are created in Tekla by using concrete columns while steel piles are created by 
using steel columns, please refer to section 4.2 in this user guide for detail.  

Users may download the Bellout.uel profile file from the CIC website if they want to model bored 
piles with bellout. Import the uel file from “Profile Catalog” which could be found in the file menu at 
the top right corner (see the user interface at “General” in this user guide). “Profile Catalog” is 
under the catalogues tag.    
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4.8 Creating Pile Caps and Tie Beams  
Pad footing is used to create a pile cap in Tekla. It is suggested to create a one big rectangular 
box model by using pad footing and then trim it by using polygon cut. It is not suggested to use 
more than one pad footing to model one pile cap as this would cause problems during 2D drawing 
production.   

 

 To minimise the use of polygon cuts, it is suggested to use custom profiles to create footing with a 
shape which can be created by simple extrusions, such as the triangular pile cap as shown below. 
Users may use “define cross-section in sketch editor” to create custom profiles.  

 Tie beams should be modelled by using strip footing under the Concrete > Footing tab.  
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4.9 Creating Reinforcement by Rebar Components and Rebar Groups. 

Click the application & components tab the right, search beam / column / wall / slab rebars to 
create rebars. Click the concrete parts such as beams and columns in modelling space to assign 
rebar. If necessary, users could right-click and select explode component after selecting specific 
rebar components, such that rebar components will be broken down to different rebar groups. This 
will not affect 2D drawing production. 

Users may also create rebar groups by clicking Rebar > Rebar group on the concrete tab. 
Properties of the rebars could be adjusted in the rebar group property menu on the right.  
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 in the rebar group property menu, it is suggested to assign rebar layer name (such as T1, T2, B1, 
B2) in the Name entry. “Prefix” in the “Numbering entry” to specify zone information (such as STR 
for superstructure or FND for foundation) and the “Start number” in the “Numbering Entry” to 
specify the bar marks.  

 The purpose of specifying zone information is to control the visibility of rebars in 3d models and 2D 
drawings. This setting could be used together with phase manager in 3d modelling mode and view 
filter function in both 3d modelling mode and 2d drawing mode to control the visibility of objects in 
complex Tekla models.  

 Users may also control end conditions of the rebar group by adjusting values in the “Hooks” 
entries in the rebar group property menu. 
 

 

 Users could also create rebars by using rebar sets. Rebar set is a powerful tool to enable users to 
create 3D rebars effectively. More settings are needed in advance for users to create rebars by 
using rebar set. For simplicity, only rebar component and rebar group are discussed in this user 
guide. No matter rebars are modelled by rebar components, rebar groups or group sets, detailed 
reinforcement drawings could also be produced by Tekla in 2D drawing mode. As both rebar 
groups and rebar sets contain information of name, numbering prefix and numbering start number. 
Tagging of rebar would not be affected during 2D drawing production.         
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4.10 Creating Steel Members for ELS  

 Steel members in excavation lateral support system could be modelled by using column and beam 
under Steel tab. Method of modelling is just similar to concrete columns and beams as specified in 
section 4.2 and 4.4 in this user guide.  

 

4.11 Creating Hoarding 
Model concrete footings of the site hoarding by using the concrete panel, as mentioned in section 
4.3. Model steel posts of site hoarding by using steel columns. After footings and steel posts were 
modelled, model a thick concrete panel to indicate the area of the covered walkway as shown in 
the pictures below. Specify the type of the hoarding in the name entry in property menu for tagging 
in 2D drawings.  
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4.12 Creating Street Furnitures 
Tekla is not designed to model street furniture such as light posts, traffic lights, guard rail, manhole 
covers, fire hydrants etc. Users may download these 3D models from Trimble SketchUp 3D 
warehouse and turn those skp files to Tekla objects.  

On the concrete tab, choose item, under the property meun pick the three dots at the right of the 
shape entry. 3D models in .tsc / .skp / .dxf / .dwg / .ifc / .ifczip / .ifcXML / .igs /iges / .dgn / .stp or 
.step format could be imported into Tekla by this method.  

Users may also buy 2D maps in dwg or dgn format from Lands Department website and import 
those files to Tekla by using the Reference model function, as mentioned in section 2.6 in this user 
guide.   

 

Sketchup 3D warehouse: 

https://3dwarehouse.sketchup.com/ 

 

 

 

  

https://3dwarehouse.sketchup.com/
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4.13 Creating Monitoring Instruments  
It is suggested to create a simple box model in Tekla to represent geotechnical monitoring 
instruments such that objects could be scheduled if needed. Users could choose whether to insert 
3D instrument model by using “shape” in “concrete items” as mentioned in section 4.12 in this user 
guide or simply use native concrete parts to create a box model such that the space consumed by 
the instrument could be adjusted inside Tekla. Name the instrument in the name entry in property 
menu such that the name could be shown by using associative note in the drawing. 
 
It is suggested to use a symbol in part mark to denote the location and type of the instrument and 
use an associative note to denote the name. Such that information could be shown clearly on 2D 
drawings, even some instruments are put very close to each other.  
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4.14 Attaching 3D topographic models   
 

 Tekla is not designed to model 3D topographic models, but users could attach 3D topographic 
models from other software to Tekla through the ‘Reference Model: function. Users need to name 
those reference model systematically in order to manage their visibility in 2D drawings.  
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4.15 Creating Ground Investigation Data  
 
Rock core samples from the bored hole and standard penetration tests results are needed to be 
modelled in 3D for drawing production. A Grasshopper script could be downloaded from the CIC 
website to facilitate users to model this information in 3D.  
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First users need to organise GI data in Excel as shown in the picturesm below for rock core samples 
in the bored hole and SPT results. Name  
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Second, after installing Rhino6 , users could type “Grasshopper” on the command bar to open 
Grasshopper. After Grasshopper is opened, go to “File” at the top left corner and choose “Open 
Document” to open the “Tekla_GI Rock Core.gh” file to open the script. 
 

 

 
 

 
 



26 
 

After the “Tekla_GI Rock Core.gh” file is opened, right-click at the “File Path Component” and choose 
the Excel file the user had prepared for rock core samples. Then right-click at the “Tekla Column 
Component” at the right and choose “Bake to Tekla” to create 3D geometries in Tekla. Those 3D 
geometries created should be assigned to the “GI” Tekla phase and could be used for 2D drawing 
production.    
 
For SPT information, open the “Tekla GI_SPT.gh” file, right-click at the “File Path Component” and 
choose the Excel file the user had prepared for SPT information and then bake those 3D object to 
Tekla by using the same method as mentioned above. 
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4.16 Creating Steel Connections  
One of the main advantages of using Tekla lies in its capability to efficiently model all kinds of steel 
connections. Many connection types have an existing parametric component that the users can 
quickly edit to create the desired connections. Components are found in the “Applications & 
components” pane where users can search for the desired connection type (e.g. “end plate”, “brace 
connection” or “shear plate”). 

Below are the search results for end plate connections. Double-clicking a component opens up its 
dialogue box where users can see how the component works and what parameters are available. 
In case of the component “End plate (101)”, the user must select two pre-existing beams in the 
model to apply the connection at their intersection. After placing the connection, users can double-
click the connection in the model to modify the parameters (e.g. set bolt spacing, size of plate etc.). 
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4.17 Creating Curtain Wall Elements 
Curtain wall elements such as transoms and mullions can be either modelled by simple rectangular 
sections (e.g. RHS) or the actual profiles can be imported to Tekla. For the latter, users can create 
user-defined sections by sketching the section or importing from a DWG file. 

 

4.18 Creating native Tekla elements from IFC objects 
It is possible to convert IFC reference model objects to native Tekla elements using the “Convert 
IFC objects” tool. Users can choose to convert a portion of, or the entire IFC model. Users can 
overview the converted properties and choose the conversion type. 

 

 
 



29 
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5 2D drawing production  

5.1 Creating GA drawings  
First In 3D modelling mode, choose the views needed for 2D drawing production. On the drawing 
tab, click create drawings > GA drawings. In the create General Arrangement Drawing pop-up 
window, choose empty drawings, tick the box of open drawing and then click “Create” 
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Now Tekla is switched from 3D modelling mode to 2D drawing mode. Double click at any blank area 
on the 2D drawings to open drawing property menu. Assign the name of this 2D drawing as shown 
below. User can also adjust drawing properties such as views, dimension, marks, objects in the 
drawing property menu. Click Modify > Apply > OK to finish.  

 

 

The name assigned in the drawing property menu can be found in the document manager after the 
user leaves this drawing close drawing mode by pressing the button as shown below. After drawing 
mode is close, Tekla would switch from drawing mode back to 3D modelling mode. 
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5.2 Inserting Views to Drawings 
In 3D modelling mode, one the Drawings & Report tab, click “Document Manager” to choose the 
drawings which needed to be edited. Double click the name of the drawing to switch from 3d 
modelling mode to drawing mode. Please note users could only delete unwanted drawings in 
Document Manager when Tekla is in 3D modelling mode. Right-click the name of the drawing in 
document manager to delete unwanted drawings. 

 

In drawing mode, one the view tab, pick Area in Model View and then choose the model view 
which is required to be put into the 2D drawings. Double click a blank area in drawing to adjust 
drawing property of the whole drawing, double click the imported view to adjust view property of 
the specific view. Users may use phase manger to categorise Tekla elements to a different phase 
and set rules in the filter in the view property menu to control whether different elements are being 
shown in drawings. In Tekla settings in view property will override settings in drawing property.   
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5.3 Creating Text and 2D Typical Details to Drawings 
 

After putting views from 3D models to drawings, users can create text. In drawing mode, on the 
annotation tab, click text to inset text on drawings.   

 

 

2D typical details could also be added in Tekla. Users may either create native Tekla 2d objects in 
drawings by using the buttons on the drawing tab as shown below or insert 2D dwg / dng files to 
Tekla directly. 2D drawing pieces could be stored in Tekla built-in 2D Library such that users could 
reuse those details in other drawings. Users can also import 2D .dwg files to the 2D library directly. 
The link below provides all necessary information about 2D Library in Tekla,  
 
https://teklastructures.support.tekla.com/2017/en/dra_details_in_drawing_2d_library 

 

  

  

https://teklastructures.support.tekla.com/2017/en/dra_details_in_drawing_2d_library
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5.4 Adding Dimensions and Marks to Drawings  
Dimensions are vital in construction drawings. After putting views from 3D models to drawings, 
users may specify dimensions to Tekla objects. This can be done by simply using the buttons on 
the dimension tab in drawing mode.  

 

In Tekla beam, columns, slabs and panels are called parts and users could add marks to parts in 
drawings. Users can create and control part marks in the drawing property menu and view the 
property menu. Besides, users could also control marks of individual part by right click at specifying 
part in drawing mode. One part could only be annotated by one mark on drawings, if users need to 
annotate additional information of specifying a part, users need to use associative notes by clicking 
the “note” button under the annotation tab in drawing mode.    
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5.5 Creating Title Blocks and Schedules to Drawings  
 

In Tekla, table-like objects (such as schedules, tables and title block or drawing frame) are created 
by using template editor to list out information. 
 

To create Title Block in Tekla, please refer to this official step-by-step video. 
 

https://teklastructures.support.tekla.com/video-tutorials/en/import-dwg-template-editor-
title-blocks 

 

 

 
  

  

https://teklastructures.support.tekla.com/video-tutorials/en/import-dwg-template-editor-title-blocks
https://teklastructures.support.tekla.com/video-tutorials/en/import-dwg-template-editor-title-blocks
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Users could also tabulate information stored in Tekla objects inside the template editor. This can 
be done by using the Value Field button in the templated editor as shown below.  
 
Value Fields in Tekla could recognise objects captured inside views inside the same drawing. 
Value Fields are needed to the put inside “Row” (the blue box) in the template editor. Users could 
also use a formula to calculate information in Tekla objects and tabulate the answer in Template 
Editor. Please refer to the link below for more information :   
 
https://teklastructures.support.tekla.com/2018/en/rel_2018_template_editor_improvements 

 

 

 
 

  

https://teklastructures.support.tekla.com/2018/en/rel_2018_template_editor_improvements
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Users may refer to drawing P004 in the sample model. The Bore Pile Loading Schedule provided 
an example of how this could be achieved by using Tekla. 
 
UDA was added to the template editor before value field was added to the template editor, please 
refer to the link below for information.  

 
https://teklastructures.support.tekla.com/2019/en/rep_adding_userdefined_attributes_to_tpl
ed 

   
 

 
 

 

  

https://teklastructures.support.tekla.com/2019/en/rep_adding_userdefined_attributes_to_tpled
https://teklastructures.support.tekla.com/2019/en/rep_adding_userdefined_attributes_to_tpled
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6 Exporting Tekla Models as Deliverables 

6.1 Exporting 3D models as ifc 
IFC model could be exported by Tekla by simply clicking Export > IFC in the File menu as shown 
below. 
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6.2 Exporting 2D drawings as pdf or dwg 
2D drawings could be exported by right click selected drawings in Document Manager in 3D 
modelling mode as shown below: 
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Feedback Form 
 
CIC BIM User Guide for Preparation of Statutory Plan Submissions Tekla 
December 2020 
 
To improve future editions of this publication, we would be grateful to have your comments.  
  
(Please put a "" in the appropriate box.) 

1. As a whole, I feel that the publication is:  Strongly  

  Agree 

Agree Neutral Disagree Strongly 

Disagree 

Informative      
Comprehensive      

Useful      
Practical      

2. Does the publication enable you to understand 
more about the subject? 

Yes No No Comment 

   
3. Have you made reference to the publication in 

your work? 

Quite Often Sometimes Never 

   
4. To what extent the publication benefits you? Strongly   

  Agree 

Agree Neutral Disagree Strongly 

Disagree 

Supply chain Information/data integrity      
Work efficiency      

Project Collaborations      
5. Overall, how would you rate our publication? Excellent Very Good Satisfactory     Fair     Poor 

     
6. Other comments and suggestions, please specify (use separate sheets if necessary). 
  
Personal Particulars (optional):* 
Name:   Mr. / Mrs./ Ms./ Dr./ Prof./ Ar. / Ir / Sr ^ 
Company:  
Tel:  
Address:  
E-mail: 
 

 
* The personal data in this form will be used only for this survey. Your data will be kept confidential and dealt 

with only by the Construction Industry Council. 
^ Circle as appropriate. 
  
Please return the feedback form to: 
CIC Secretariat – BIM 
E-mail:              bim@cic.hk; 
Address:           38/F, COS Center, 56 Tsun Yip Street, Kwun Tong, Hong Kong 
Fax No.: (852) 2100 9090 
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Preface



The Construction Industry Council (CIC) is committed to seeking continuous improvement in all aspects of the construction industry in Hong Kong. To achieve this aim, the CIC forms Committees, Task Forces and other forums to review specific areas of work with the intention of producing Alerts, Reference Materials, Guidelines and Codes of Conduct to assist participants in the industry to strive for excellence.

The CIC appreciates that some improvements and practices can be implemented immediately whilst others may take more time for implementation. It is for this reason that four separate categories of publication have been adopted, the purposes of which are as follows:



		Alerts

		The Alerts are reminders in the form of brief leaflets produced quickly to draw the immediate attention of relevant stakeholders to the need to follow some good practices or to implement some preventive measures in relation to the construction industry.





		Reference Materials

		The Reference Materials are standards or methodologies generally adopted and regarded by the industry as good practices. The CIC recommends the adoption of the Reference Materials by industry stakeholders where appropriate.





		Guidelines

		The Guidelines provide information and guidance on particular topics relevant to the construction industry. The CIC expects all industry stakeholders to adopt the recommendations set out in the Guidelines where applicable.





		Codes of Conduct

		The Codes of Conduct set out the principles that all relevant industry participants should follow. Under the Construction Industry Council (Cap 587), the CIC is tasked to formulate codes of conduct and enforce such codes. The CIC may take necessary actions to ensure compliance with the codes.







If you have read this publication, we encourage you to share your feedback with us. Please take a moment to fill out the Feedback Form attached to this publication in order that we can further enhance it for the benefit of all concerned. With our joint efforts, we believe our construction industry will develop further and will continue to prosper for years to come.




[bookmark: _Toc58920275]Foreword

I am glad to see the release of CIC BIM User Guide for Preparation of Statutory Plan Submissions Tekla (December 2020). This software specific user guide shall be read in conjunction with the CIC BIM Standards for Preparation of Statutory Plan Submissions (December 2020). 

This software specific user guide is only provided to demonstrate the feasibility of drawings generation with the Standards. 

With the software specific user guides which contains step by step procedures of modelling, BIM users can easily apply the templates for the generation of statutory plan submission drawings.

Feedback on the CIC BIM User Guide for Preparation of Statutory Plan Submissions Tekla (December 2020) from practitioners subsequent to the issuance of this publication will be considered in future revisions. 

On behalf of the CIC, I would like to thank everyone who has contributed to producing this CIC BIM User Guide for Preparation of Statutory Plan Submissions Tekla (December 2020), in particular to the members of the Task Force on BIM Standards.



Ar. Ada FUNG, BBS

Chairperson 

Committee on Building Information Modelling

Construction Industry Council

December 2020











[bookmark: _Toc59310080]Hardware / System Requirements

[bookmark: _Toc58920763][bookmark: _Toc59309268][bookmark: _Toc59310081]

[bookmark: _Toc59310082]General 

Hardware / system requirement for modellings, coordination and visualization visualisation on desktop/notebook computers and mobile devices should be determined by the BIM managers for different projects on a case by case basis. Minimum The minimum requirement varies for different applications, project sizes and operating systems.


https://teklastructures.support.tekla.com/support-articles/tekla-structures-2019-hardware-recommendations




[bookmark: _Toc58920765][bookmark: _Toc59309270][bookmark: _Toc59310083]

[bookmark: _Toc59310084]Tekla Basics



This guideline only provides the necessary information to produce 2D statutory submission drawings. Please refer to the official website linked below for a complete understanding of Tekla.  
https://teklastructures.support.tekla.com/tekla-structures-2019-pdf-documentation



[bookmark: _Toc59310085]User Interface

Information of user interface could be found in the official website here:

https://teklastructures.support.tekla.com/2019/en/gen_interface_overview



[bookmark: _Toc59310086]Project base point, Grid, Levels and Work Planes	


Project base point defines the origin (0,0,0) of the project coordinate system initially Location of point can be determined by the project team or BIM manager as a reference point. Steps to set up project base points in Tekla could be found from the official website here : 

https://teklastructures.support.tekla.com/2019/en/int_base_point

Grids and Levels are essential for users to model and identify objects in Tekla effectively, Steps to set up girds and levels in Tekla could be found from the official website here : 

https://teklastructures.support.tekla.com/2019/en/mod_grids

https://teklastructures.support.tekla.com/2019/en/mod_creating_a_grid

Work Plane is a vital concept for users to model objects in Tekla, this official link is useful for users to understand work planes in Tekla :

https://teklastructures.support.tekla.com/190/en/mod_work_plane

[bookmark: _Toc59310087]Parts and Components

Tekla objects could be classified into parts, components, assemblies, cast units etc. In this user guide, users mainly need to use parts (for example; concrete parts such as beam, column, slabs and panels) and components (for example; rebar components). These official web pages provide good guidance for creating parts in Tekla:


https://teklastructures.support.tekla.com/190/en/mod_creating_and_modifying_structures



https://teklastructures.support.tekla.com/190/en/mod_creating_concrete_slab?da=_


Components in Tekla could greatly increase the efficiency of modelling works, information about components could be found in this official web site:  


https://teklastructures.support.tekla.com/2017i/en/det_getting_started_overview

[bookmark: _Toc59310088]Catalogs and Define Profiles

[bookmark: _Hlk10043876]Tekla allow users to define customized customised profiles for members sections; users may refer to the link below for more information 

https://teklastructures.support.tekla.com/2019/en/mod_profiles. 

[bookmark: _Toc59310089]Phases, View Filter and OrganizerOrganiser

Phases are usually used by Tekla users to classify different object-groups (such as ELS, foundations or superstructures) in Tekla, differ from Revit, phase not necessarily be used to record sequential data of objects in Tekla. Users may use “Pour Phase” in Tekla to record chronological information of Tekla concrete parts. For steel parts and assemblies, part or assembly numbers are commonly used to achieve the same goal.

https://teklastructures.support.tekla.com/2019/en/mod_dividing_the_model_into_phases

In order to do 3d-modelling and produce drawings efficiently, phases are often used together with the view filter. In fact, vView filter could also be used to control the visibility of different Tekla elements. More information about view filters could be found from the official website below : 

https://teklastructures.support.tekla.com/190/en/mod_creating_a_view_filter


https://teklastructures.support.tekla.com/190/en/mod_filtering_parts_in_specific_phases

Organizers Organisers are used mainly for quantity take off purpose in Tekla, this web page provides more information about organizer organiser in Tekla, in this document, organizer organiser would not be discussed as it is not related to statuary drawing submissions. 

https://teklastructures.support.tekla.com/2019/en/mod_organizer



[bookmark: _Toc59310090]Suggested Model Nesting Method, Reference Models and Model Sharing

Tekla is not designed to link-up with other Tekla models. For users who want to link two Tekla models together, they need to export one Tekla model as ifc and add that ifc model to another model via the “Reference Model” function in Tekla.

Information about the reference model could be found in this official web page ; files such as ifc, dwg, dgn, skp, xml, etc. could all be linked to Tekla by using this method.
  
https://teklastructures.support.tekla.com/2019/en/int_inserting_a_reference_model


2D reference information, such as 2D dwg/dgn maps bought from the Lands Department website shall also be linked to Tekla file by using a reference model.

Tekla allow multi-user-editing, please refer this web page for “Model Sharing” in Tekla

https://teklastructures.support.tekla.com/2019/en/ms_what_is_model_sharing

[bookmark: _Toc59310091]Views and Drawings

Views in Tekla are used to facilitate both 3D-modeling works and 2D drawing production. This web page summarizes summarises information about views in Tekla.

https://teklastructures.support.tekla.com/2019/en/mod_views


Users could produce 2D drawings after creating different views in Tekla. There are five different drawing types in Tekla, namely (1) general arrangement drawings, (2) single-part drawings, (3) assembly drawings, (4) Cast-unit drawings and (5) Multidrawings. 

For the production of statutory-submission, only general arrangement drawings will be discussed in this user guide. Please refer to the link below for more information about creating general drawings by Tekla. Tekla will be switched from modelling mode to drawing mode for drawing production.

https://teklastructures.support.tekla.com/2019/en/dra_creating_ga_drawings_using_menu_toolbar_or_popup



[bookmark: _Toc59310092]Annotation and Dimensioning

Users can create annotation and dimensions on drawings in drawing mode. Below are some web page links for more information. 

https://teklastructures.support.tekla.com/2019/en/dra_arranging_drawing_objects

https://teklastructures.support.tekla.com/2019/en/dra_manual_dimensions




[bookmark: _Toc59310093]Template Editor, Tables and Drawing Layout

Drawing frames, or so we call title block, were produced by template editor in Tekla. Template editor could also be used to produce schedules or tables in 2D drawings. This video provides a brief introduction about template editor in Tekla.  

https://teklastructures.support.tekla.com/video-tutorials/en/layout_editor

https://teklastructures.support.tekla.com/system/files/document_attachments/TE_USG_380_en_Template_editor_user_guide.pdf

This video shows how the template editor could be used to produce schedules in 2D drawings. 

https://teklastructures.support.tekla.com/video-tutorials/en/introduction_to_template_editor

 

[bookmark: _Toc59310094]2D Library and Symbol Editor

Tekla has some features to enable users to manage 2D drawing pieces and 2D symbols. They are namely the 2D Library and symbol editor. Please refer to the links below for more information.  

https://teklastructures.support.tekla.com/video-tutorials/en/2d_library

https://teklastructures.support.tekla.com/video-tutorials/en/add_symbols

https://teklastructures.support.tekla.com/system/files/document_attachments/SE_USG_300_en_Symbol_editor_user_guide.pdf

[bookmark: _Toc59310095]User Define Attributes

Tekla enables users to introduce user-defined-attributes (UDA) to manage information of about Tekla objects. An example of applying UDA to Tekla objects is provided as bored piles in the sample models. This requests users to acquire advanced Tekla skills, including some basic coding skills. For those who are interested, please refer to the link below, this user guide would not discuss this in detail.

https://teklastructures.support.tekla.com/cs/191/en/sys_example_creating_and_updating_uda


To manage UDA efficiently, Users may also search UDA in Tekla Warehouse and install more extensions:

https://warehouse.tekla.com/#!/search/?searchTerm=uda


Information stored in Tekla as UDA could also be exported to IFC as IFC property set, please refer to the link below for more information ;

https://teklastructures.support.tekla.com/2019/en/int_defining_property_sets_using_property_set_definitions




[bookmark: _Toc59310096]Getting Start



Users are expected to install Tekla 2019i before followings the steps stated in this section.

[bookmark: _Toc59310097]Opening Project Template

Download template file from CIC website. Run the Env_SE_Asia_2019.exe to install Asian Tekla tool set. Put the folder set ““CIC_TEMPLATE_STR_2019”CIC_DEMO_MODEL_TEMPLATE” to C:\ProgramData\Trimble\Tekla Structures\2019.0\Environments\SE_Asia\Precast\model_templates.


[image: ]


Open Tekla 2019, open new file with template “CIC_DEMO_MODEL_TEMPLATE” being chosen.

[image: ]

[bookmark: _Toc59310098]Set-up of Project Base Points 



[image: ]Chose a reference point in the target project. Enter the Easting and Northing coordinates to Tekla by clicking the “base point” button in the project property menu as shown in the pictures below





[bookmark: _Toc59310099]Creating Grids 



On the Edit tab, click Grid > Create rectangular grids as shown in the picture below; click “create rectangular grids” again to create another grid system if needed. User The user could also create radial grids by choosing “Create radial grid”. Unlike Revit, Tekla uses grids in the Z dimension to define building levels. For details about grids in Tekla, please refer to the reference links in section 2.2 in this user guide. 



Grids are useful to control 3D objects in Tekla. Users could switch on or switch off the magnetic function of grids. Magnetic The magnetic function is also available in construction lines and planes in Tekla. Users could use construction lines and construction planes as a temporary 3D reference during 3D modelling. Please refer to the link below for more information: 

https://teklastructures.support.tekla.com/video-tutorials/en/magnetic_construction_objects


[image: ]


[bookmark: _Toc59310100]Creating Model Objects





The following objects will be modelled in Tekla:

· Slab

· Column

· Wall

· Beam

· Lift Shaft

· Staircase

· Piles

· Pile Caps

· Tie Beams

· Reinforcement

· Steel members for ELS

· Hoarding

· Geotechnical Monitoring instruments






[bookmark: _Toc59310101]Creating Slabs

On the View tab, click View tab > new view > along gridline to create views for specific floor levels, click Work Plane > Parallel to view plane to create work plane parallel to the view. For the snap settings which could be adjusted at the right bottom corner choose a plan, work plan and grid plane in the three put down the menu. Press ctrl+P to get a top view in Tekla modelling space,

[image: ]

On the 


Concrete tab, click Slab > Slab as shown in the picture below, left left-click to define corner points of the slab, press middle mouse button to finish. Slab thickness can be adjusted in the property menu on the right.

[image: ]




[bookmark: _Toc59310102]Creating Columns

On the Concrete tab, click Column to create a column. Left Left-click in 3D model space to create a column. In the property menu, assign a name for the column; simply change the numbers in the profile entry in property menu (such as 250*675 or 400*600) to adjust column size; type D-diameter length (such as D1800) to change it to a circular column. Press three dots at the right for specific section profile. Change values in Top and Bottom to adjust column elevation. Right Right-click the column and choose move special > linear to fine adjust the position of the column in 3D space.    

[image: ]
[image: ]

[image: ]


[bookmark: _Toc59310103]Creating Panels ( Walls )

On the concrete tab, click Panel > Panel to create walls. left Left-click to define wall alignment on the plan view, press middle mouse button to finish. In the property menu, assign a name for the wall, Wall height and wall thickness can be adjusted in the profile entry in the property menu.


[image: ]




[bookmark: _Toc59310104]Creating Beams

On the Concrete tab, click Beam > beam to create beams. Left Left-click in 3D model space to define end points of the beam. In the property menu, assign a name for the beams; like columns, simply change the numbers in the profile entry in property menu (such as 400*600 or 200*300) to adjust beam size; press three dots at the right for specific section profile. Right Right-click the beams and choose move special > linear to fine adjust the position of the beams in 3D space.



[image: ] 


For specially shaped beams such as haunch beam, stepped beams and cranked beams, it is suggested to use polygon cut to remove unwanted portion of the beam.



[image: ]








[bookmark: _Toc59310105]Creating Slab Openings 

Left Left-click the slab which needs to create slab opening, on the concrete tab, Press “ctrl+P” to get a top view in Tekla modelling space, choose polygon cut on the concrete tab to create slab opening.

[bookmark: _Toc59310106]Creating a Staircase

Click the application & components tab the right, search stair and chose concrete stair (component number 65) to create stair. Double-click the blue “M” symbol to adjust the properties of a component, click Modify > Apply > Okay to finish. Click the green buttons at the selection switches at the bottom to enable/disable user’s ability to choose parts inside components. Delete unwanted components if necessary. Deleted parts in the component will be regenerated whenever users click Apply > Okay in the component property menu. 

[image: ][image: ]




[bookmark: _Toc59310107]Creating Piles



Concrete piles are created in Tekla by using concrete columns while steel piles are created by using steel columns, please refer to section 4.2 in this user guide for detail. 

Users may download the Bellout.uel profile file from the CIC website if they want to model bored piles with bellout. Import the uel file from “Profile Catalog” which could be found in the file meun menu at the top right corner (see the user interface at “General” in this user guide). “Profile Catalog” is under the catalogues tag.   

[image: ]

[image: ]


[bookmark: _Toc59310108]Creating Pile Caps and Tie Beams 

[image: ]





Pad footing is used to create a pile cap in Tekla. It is suggested to create a one big rectangular box model by using pad footing and then trim it by using polygon cut. It is not suggested to use more than one pad footing to model one pile cap as this would cause problems during 2D drawing production.  




To minimize minimise the use of polygon cuts, it is suggested to use custom profiles to create footing with a shape which can be created by simple extrusions, such as the triangular pile cap as shown below. Users may use “define cross cross-section in sketch editor” to create custom profiles. 



Tie beams should be modelled by using strip footing under the Concrete > Footing tab. 

[image: ]





[bookmark: _Toc59310109]Creating Reinforcement by Rebar Components and Rebar Groups.

Click the application & components tab the right, search beam / column / wall / slab rebars to create rebars. Click the concrete parts such as beams and columns in modelling space to assign rebar. If necessary, users could right right-click and select explode component after selecting specific rebar components, such that rebar components will be broken down to different rebar groups. This will not affect 2D drawing production.

[image: ][image: ]Users may also create rebar groups by clicking Rebar > Rebar group on the concrete tab. Properties of the rebars could be adjusted in the rebar group property menu on the right. 






in the rebar group property menu, it is suggested to assign rebar layer name (such as T1, T2, B1, B2) in the Name entry. “Prefix” in the “Numbering entry” to specify zone information (such as STR for superstructure or FND for foundation) and the “Start number” in the “Numbering Entry” to specify the bar marks. 

The purpose of specifying zone information is to control the visibility of rebars in 3d models and 2D drawings. This setting could be used together with phase manager in 3d modelling mode and view filter function in both 3d modelling mode and 2d drawing mode to control the visibility of objects in complex Tekla models. 

Users may also control end conditions of the rebar group by adjusting values in the “Hooks” entries in the rebar group property menu.

[image: ]



Users could also create rebars by using rebar sets. Rebar set is a powerful tool to enable users to create 3D rebars in an effective waeffectively. More settings are needed in advance for users to create rebars by using rebar set. For simplicity, only rebar component and rebar group are discussed in this user guide. No matter rebars are modelled by rebar components, rebar groups or group sets, detailed reinforcement drawings could also be produced by Tekla in 2D drawing mode. As both rebar groups and rebar sets contain information of name, numbering prefix and numbering start number. Tagging of rebar would not be affected during 2D drawing production.       


[bookmark: _Toc59310110]Creating Steel Members for ELS 



Steel members in excavation lateral support system could be modelled by using column and beam under Steel tab. Method of modelling is just similar to concrete columns and beams as specified in section 4.2 and 4.4 in this user guide. 

[image: ]


[bookmark: _Toc59310111]Creating Hoarding

[image: ]

Model concrete footings of the site hoarding by using the concrete panel, as mentioned in section 4.3. Model steel posts of site hoarding by using steel columns. After footings and steel posts were modelled, model a thick concrete panel to indicate the area of the covered walkway as shown in the pictures below. Specify the type of the hoarding in the name entry in property menu for tagging in 2D drawings. 




[image: ][image: ]




[bookmark: _Toc59310112]Creating Street Furnitures

Tekla is not designed to model street furniture such as light posts, traffic lights, guard rail, manhole covers, fire hydrants etc. Users may download these 3D models from Trimble SketchUp 3D warehouse and turn those skp files to Tekla objects. 

On the concrete tab, choose item, under the property meun pick the three dots at the right of the shape entry. 3D models in .tsc / .skp / .dxf / .dwg / .ifc / .ifczip / .ifcXML / .igs /iges / .dgn / .stp or .step format could be imported into Tekla by this method. 

Users may also buy 2D maps in dwg or dgn format from Lands Department website and import those files to Tekla by using the Reference model function, as mentioned in section 2.6 in this user guide.  



Sketchup 3D warehouse:

https://3dwarehouse.sketchup.com/



[image: ]






[bookmark: _Toc59310113]Creating Monitoring Instruments 



[image: ]It is suggested to create a simple box model in Tekla to represent geotechnical monitoring instruments such that objects could be scheduled if needed. Users could choose whether to insert 3D instrument model by using “shape” in “concrete items” as mentioned in section 4.12 in this user guide or simply use a native concrete parts to create a box model such that the space consumed by the instrument could be adjusted inside Tekla. Name the instrument in the name entry in property meun menu such that the name could be shown by using associative note in the drawing.

 It is suggesteed to use a symbol in part mark to denote the location and type of the instrument and use an associative note to denote the name. such Such that information could be shown clearly on 2D drawings, even some instruments are put very close to each other. [image: ]




[bookmark: _Toc59310114]Attaching 3D topographic models  


Tekla is not designed to model 3D topographic models, but users could attach 3D topographic models from other software to Tekla through the ‘Reference Model: function. Users need to name those reference model in a systematic wasystematically in order to manage their visibility in 2D drawings. 





[image: ]
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[bookmark: _Toc59310115]Creating Ground Investigation Data 


Rock core samples from the bored hole and standard penetration tests results is are needed to be modelled in 3D for drawing production. A Grasshopper script could be downloaded from the CIC website to facilitate users to model these this information in 3D. 



[image: ][image: ]


First users need to organize organise GI data in Excel as shown in the picturesm below for rock core samples in the bored hole and SPT results. Name 

 [image: ][image: ]
Second, after installing Rhino6 , users could type “Grasshopper” on the command bar to open grasshopperGrasshopper. After Grasshopper is opened, go to “File” at the top left corner and choose “Open Document” to open the “Tekla_GI Rock Core.gh” file to open the script.

[image: ]



[image: ]



Atfer After the “Tekla_GI Rock Core.gh” file is opened, right right-click at the “File Path Component” and choose the Excel file the user had prepared for rock core samples. Then right right-click at the “Tekla Column Component” at the right and choose “Bake to Tekla” to create 3D geometries in Tekla. Those 3D geometries created should be assigned to the “GI” Tekla phase and could be used for 2D drawing production.   

For SPT information, open the “Tekla GI_SPT.gh” file, right right-click at the “File Path Component” and choose the Excel file the user had prepared for SPT information and then bake those 3D object to Tekla by using the same method as mentioned above.


[image: ]

[image: ]

[bookmark: _Toc59310116]
Creating Steel Connections 

One of the main advantages of using Tekla lies in its capability to efficiently model all kinds of steel connections. Many connection types have an existing parametric component that the users can quickly edit to create the desired connections. Components are found in the “Applications & components” pane where users can search for the desired connection type (e.g. “end plate”, “brace connection” or “shear plate”).

Below are the search results for end plate connections. Double-clicking a component opens up its dialogue box where users can see how the component works and what parameters are available. In case of the component “End plate (101)”, the user must select two pre-existing beams in the model to apply the connection at their intersection. After placing the connection, users can double-click the connection in the model to modify the parameters (e.g. set bolt spacing, size of plate etc.).

[image: ]



[image: ]   [image: ]

[bookmark: _Toc59310117]
Creating Curtain Wall Elements

Curtain wall elements such as transoms and mullions can be either modelled by simple rectangular sections (e.g. RHS) or the actual profiles can be imported to Tekla. For the latter, users can create user user-defined sections by sketching the section or importing from a DWG file.

[image: ]

[bookmark: _Toc59310118]Creating native Tekla elements from IFC objects

It is possible to convert IFC reference model objects to native Tekla elements using the “Convert IFC objects” tool. Users can choose to convert a portion of, or the entire IFC model. Users can overview the converted properties and choose the conversion type.



[image: ]



[image: ] 



[image: ] 




[bookmark: _Toc59310119]2D drawing production 

[bookmark: _Toc59310120]Creating GA drawings 



First In 3D modelling mode, choose the views needed for 2D drawing production. On the drawing tab, click create drawings > GA drawings. In the create General Arrangement Drawing pop-up window, choose empty drawings, tick the box of open drawing and then click “Create”

[image: ]



[image: ]

Now Tekla is switched from 3D modelling mode to 2D drawing mode. Double click at any blank area on the 2D drawings to open drawing property menu. Assign the name of this 2D drawing as shown below. User can also adjust drawing properties such as views, dimension, marks, objects in the drawing property menu. Click Modify > Apply > OK to finish. 

[image: ]

[image: ]

The name assigned in the drawing property menu can be found in the document manager after the user leaves this drawing close drawing mode by pressing the button as shown below. After drawing mode is close, Tekla would switch from drawing mode back to 3D modelling mode.

[image: ] 


[bookmark: _Toc59310121]Inserting Views to Drawings

[image: ]In 3D modelling mode, one the Drawings & Report tab, click “Document Manager” to choose the drawings which needed to be edited. Double click the name of the drawing to switch from 3d modelling mode to drawing mode. Please note users could only delete unwanted drawings in Document Manager when Tekla is in 3D modelling mode. Right Right-click the name of the drawing in document manager to delete unwanted drawings.



In drawing mode, one the view tab, pick Area in Model View and then choose the model view which is required to be put into the 2D drawings. Double click at blank area in drawing to adjust drawing property of the whole drawing, double click the imported view to adjust view property of the specific view. Users may use phase manger to categorize categorise Tekla elements to a different phase and set rules in the filter in the view property menu to control whether different elements are being shown in drawings. In Tekla settings in view property will override settings in drawing property.  

[image: ]






[bookmark: _Toc59310122]Creating Text and 2D Typical Details to Drawings



After putting views from 3D models to drawings, users can create text. In drawing mode, on the annotation tab, click text to inset text on drawings.  



[image: ]



2D typical details could also be added in Tekla. Users may either create native Tekla 2d objects in drawings by using the buttons on the drawing tab as shown below or insert 2D dwg / dng files to Tekla directly. 2D drawing pieces could be stored in Tekla built-in 2D Library such that users could reuse those details in other drawings. Users can also import 2D .dwg files to the 2D library directly. The link below provides all necessary information about 2D Library in Tekla, 

https://teklastructures.support.tekla.com/2017/en/dra_details_in_drawing_2d_library



[image: ]	




[bookmark: _Toc59310123]Adding Dimensions and Marks to Drawings 

[image: ]Dimensions are vital in construction drawings. After putting views from 3D models to drawings, users may specify dimensions to Tekla objects. This can be done by simply using the buttons on the dimension tab in drawing mode. 



[image: ]In Tekla beam, columns, slabs and panels are called parts and users could add marks to parts in drawings. Users can create and control part marks in the drawing property meun menu and view the property meunmenu. Besides, users could also control marks of individual part by right click at specifying part in drawing mode. One part could only be annotated by one mark on drawings, if users need to annotate additional information of specifying a part, users need to use associative notes by clicking the “note” button under the annotation tab in drawing mode.   




[bookmark: _Toc59310124]Creating Title Blocks and Schedules to Drawings 



In Tekla, table-like objects (such as schedules, tables and title block or drawing frame) are created by using template editor to list out information. 


To create Title Block in Tekla, please refer to this official step-by-step video.


https://teklastructures.support.tekla.com/video-tutorials/en/import-dwg-template-editor-title-blocks




[image: ]
 




Users could also tabulate information stored in Tekla objects inside the template editor. This can be done by using the Value Field button in the templated editor as shown below. 

Value Fields in Tekla could recognize recognise objects captured inside views inside the same drawing. Value Fields are needed to the put inside “Row” (the blue box) in the template editor. Users could also use a formula to calculate information in Tekla objects and tabulate the answer in Template Editor. Please refer to the link below for more information :  

https://teklastructures.support.tekla.com/2018/en/rel_2018_template_editor_improvements

[image: ]
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Users may refer to drawing P004 in the sample model. The Bore Pile Loading Schedule provided an example for of how this could be achieved by using Tekla.

UDA was added to the template editor before value field was added to the template editor, please refer to the link below for information. 


https://teklastructures.support.tekla.com/2019/en/rep_adding_userdefined_attributes_to_tpled

  

[image: ]
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[bookmark: _Toc59310125]Exporting Tekla Models as Deliverables

[bookmark: _Toc59310126]Exporting 3D models as ifc

IFC model could be exported by Tekla by simply clicking Export > IFC in the File menu as shown below.

[image: ] 




[bookmark: _Toc59310127]Exporting 2D drawings as pdf or dwg

2D drawings could be exported by right click selected drawings in Document Manager in 3D modelling mode as shown below:



[image: ][image: ]










Feedback Form



CIC BIM User Guide for Preparation of Statutory Plan Submissions Tekla December 2020
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